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Objective: 

Learn how to delineate a watershed for a point of interest using a digital elevation model (DEM) 

and the ArcGIS Spatial Analyst Extension 

Background: 
 

A digital elevation model (DEM) is a regularly spaced grid of numbers representing elevation – 

it is the digital equivalent of a topographic map. Typical DEM data has a resolution of 1 arc sec 

(approx 30 m) or 1/3 arc sec (~10 m). 1/9 arc sec data is also available for some. Keep in mind 

that the higher the resolution, the more accurate the elevations, but the larger the files you’ll be 

working with (3X better resolution = 9X larger files). The resolution to use depends on the scale 

of the problem you are working on – for example, for large watersheds using 10 m vs. 30 m 

resolution has very little effect on the results.  

 

Watersheds can be delineated in Geographical Information Systems (GIS) by keeping track of 

flow direction and number of upstream points for each grid point in a DEM. Once the watershed 

is delineated it can then be used to crop out data from other layers (e.g. land cover, area, etc), that 

are useful in hydrology. We will use the Spatial Analyst extension in ArcGIS. 

 

Data Acquisition: 
 

Download the DEM from http://viewer.nationalmap.gov/viewer/. To select the desired area, 

zoom in to MA. Under the Advanced Tab, click the first icon, “download by bounding box”. It is 

important that you leave some extra room around the boundary that you want to analyze but do 

not make the area too big because processing the data in GIS can take a very long time with big 

files. Click to draw the rectangle and then release when it is the size you want. Check off 

elevation and click next. Check the 1/3 arc second dataset that is in the Arc Grid format, click 

next. Click checkout. Enter your e-mail address, and place order. You can now download the 

DEM from your e-mail. Once you select “click here to download” from your e-mail select save.  

 

I have provided a folder called MA Sate Boundary. This is so you can see where the DEM is 

placed within the state line.  

 

Procedure: 
 

Preliminaries 

 
1. Create a New Folder on your flash drive and call it CEE 577 GIS. Copy the downloaded file 

into this new folder. GIS files need to be organized or you will have problems when trying to 

access the data later. Right click the zipped folder in CEE 577 GIS and select “7-Zip” and then 

“Extract Here”. It will take a minute or two for all of the files to be extracted.  



TIP: It may seem like there are a lot of extra files that what you may need. Do NOT move or 

delete these files. GIS uses these extra files when you upload the layers and you will receive 

errors if these files are removed (this is why organization is important).  

 
2. Start ArcMap by double clicking the desktop icon or do Start > All Programs > ArcGIS > 

ArcMap. Open a new empty map. 

 
TIP: To save your map to return to it later, you need to go to file, map document properties, and 

check off store relative pathnames to data sources. If you do not do this and change computers 

GIS will not be able to find your files and you will have to upload them again.  

 

3. Your screen should have three panels like the image below: 
 

 
 

3. Click the yellow plus sign to Add Data (red box in image) – navigate to your CEE 577 GIS 

folder and add the DEM file (icon that looks like a yellow grid – this icon represents a Raster 

file, meaning a grid of numbers) 

 

If your folder is not shown, click on the ArcCatalog icon (looks like a yellow & blue file cabinet, 

highlighted by blue box), and then click the “Connect to folder” button (a yellow arrow) and 

browse to the folder. Now you should be able to Add Data in ArcMap. 

 

The DEM should appear as a gray shaded topographic map in the right-hand panel 

 

4. Click the yellow plus sign to Add Data again. Navigate to MA State Boundary folder. Select 

states.shp and add. On the left side where your data layers are located click the colored box 

under states. Choose “no color” under “Fill color” and increase the outline width to 1.00. This 

will allow you to see both the DEM and the state boundary.  



5. You MUST check the projection of these files before you can do any data analysis. Failure to 

do this step can result in inaccurate results and a very large headache. First right click “states” 

and click “properties”. Under the Source tab it will tell you that the Projected Coordinate System 

is NAD_1983_UTM_Zone_18N and the Geographic Coordinate System is 

GCS_North_American_1983. Now right click on the DEM layer, select properties and go to the 

source tab. Its spatial reference is also GCS_North_American_1983 so we don’t have to change 

anything this time. 

 

Delineation 

 

Part 1  

 

1. It is important to use a DEM with no depressions or sinks, so we first have to “fill” the DEM. 

 

A sink is a cell or set of spatially connected cells whose flow direction cannot be assigned one of 

the eight valid values in a flow direction raster. Sinks in elevation data are most commonly due 

to errors in the data. These errors are often caused by sampling effects and the rounding of 

elevations to integer numbers. As the cell size increases, the number of sinks in a dataset also 

often increases.  

 

To create an accurate representation of flow direction and, therefore, accumulated flow, it is best 

to use a dataset that is free of sinks. A digital elevation model (DEM) that has been processed to 

remove all sinks is called a depressionless DEM. The identification and removal of sinks, when 

creating a depressionless DEM, is an iterative process. When a sink is filled, the boundaries of 

the filled area may create new sinks that need to be filled. 

 

 
 

To fill the sinks, click on the red toolbox to display the Arc Toolbox. Select Spatial Analyst 

Tools > Hydrology > Fill 

 

Under “Input surface raster” box, click the down arrow and select the file to be filled (the 

projected DEM, in our case grdn43w073_13). It will do the rest for you – select OK. This will 

take a few minutes to complete.  

 

TIP: If you aren’t sure if GIS is running look at the bottom right of the screen and you should 

see Fill…Fill…Fill in blue which means that GIS is working. 

 

You may also want to change the color scheme of the DEM – click on the Color Ramp (in the 

Layers panel) and select a different one. You can change the color scheme for any layer this way. 

If you want Red to represent higher numbers then click invert. 



2. Now we need to determine the slope direction at each pixel, i.e. the “aspect” of the terrain 

 

Under the Spatial Analyst Tools, again select Hydrology and then Flow Direction 

 

Under “Input surface raster” box, click the down arrow and select the filled DEM layer and then 

OK. Again this will take a few minutes. You should see Flow Direction…Flow Direction…in the 

bottom right corner.  

 

You should now see a new layer(FlowDir_xxxx) in which each pixel has one of eight colors, 

representing the direction of slope (East is 1, Southeast is 2, South is 4, Southwest is 8, West is 

16, Northwest is 32, North is 64, and Northeast is 128) 

 

3. Now we determine the “flow accumulation”, that is, the number of up gradient pixels that 

slope toward each point in the DEM grid 

 

Select Spatial Analyst Tools > Hydrology > Flow Accumulation 

 

Under “Input surface raster” box, click the down arrow and select the FlowDir layer then OK. 

This is the longest waiting step.  

 

TIP: If at any point GIS says “not responding” and looks like it is freezing do NOT click 

anything or try to exit out of the program. Many times GIS will do this as it is finishing up a 

layer and will correct itself.  

 

You should now see a network of white pixels that look like a stream network (these are not 

necessarily streams, however) 

 

Part 2 
 

1. We now need to add a point that represents the outlet of our watershed. This takes a couple 

steps. We need to create, add, and edit a “shape file” that has the outlet for the watershed. To do 

this, start up ArcCatalog (click on the file cabinet icon), browse to the folder that has your DEM 

layer files. Right-click in the folder and add a New > Shapefile.  

 

 

A dialog box will come up – name the layer (eg “Outlet”), select Point for feature type, and then 

click the Edit button to give the new shapefile a coordinate system. Click Edit and then 

Select…> Projected Coordinate Systems > UTM > NAD 1983 > NAD 1983 UTM Zone 18N.prj 

> Add > Apply > OK.  

 

2. Go back to ArcMap. Click the yellow plus sign to Add Data, select one of the new shapefiles, 

for now select Outlet.shp (green icon). 

 

Now we have to figure out what the locations are of these drainage points. To do this, I looked at 

Google maps and changed the coordinates until they were very close to where the brooks started. 

My coordinates for the Outlet were 42.274465,-72.4704. On ArcMap, there should be a blue 

point that has XY underneath it, press this icon. This allows you to select a specific location on 



the map. Change the units to decimal degrees. Enter -72.4704 for X and 42.274465 for Y. Press 

the point with XY underneath it (add labeled point). The point should show up on your map.  

 

Now zoom in on the Flow Accumulation layer so that you can add the outlet point at exactly the 

right pixel. 

 

3. Once you have zoomed in, go to the Editor toolbar under the Tools menu, select Start Editing. 

Make sure to select which folder to use whichever one has the newly created shape file for the 

outlet point. Now click “Start Editing”, and use the “Sketch Tool” (pencil icon) to place the red 

bulls eye directly over the pixel that is closest to the green dot that we placed from add XY point 

and click. This is where we are putting the outlet. Go back to the editor and slick stop editing. It 

will ask if you want to save your changes, click save. 

 

TIP: If you are off the stream channel by so much as one pixel you will not delineate the correct 

drainage area. Your outlet point must be in a flow channel pixel. 

 

Part 3 

 

1. We are ready to delineate, but we need to be sure the program will perform the delineation for 

the entire extent of the DEM (it is not smart enough to do that until you tell it): 

 

First go to Tools > Options > Geoprocessing > Environments > General Settings > scroll down 

to Extent and select “same as layer Fill_xxxxx”. 

 

Now select Spatial Analyst Tools > Hydrology > Watershed 

 

Under the “Input flow direction raster” box, click the down arrow and select the FlowDir layer 

Under “Input raster or feature pour point data”, click the down arrow and select Outlet. Change 

the location of your output raster to your CEE 577 GIS folder.  

 

TIP: For some reason GIS does not like the pathname to be too long. If you save the file with 

too many letters you may get a red x and have no idea what the problem is. Instead of labeling 

the point as Outlet_Watershed, try something like Outlet_wshd for example, then OK. 

 

You will get new layer that is the shape of the watershed finally! 

 

2. Convert this layer from a raster to a polygon – it will allow us to display the data better and 

will allow some additional analysis (such as calculating area)  

 

Select Arc Toolbox > Conversion Tools > From Raster > Raster to Polygon 

 

Under “Input raster” box, click the down arrow and select Outlet_wshd. Save the file in your 

folder and name it Outlet_wtshd and then OK 

 

You will get a new layer named Outlet_wtshd 

 



Double-click on the box below your new shapefile Outlet_wtshd. Under Options – Fill color, 

select No Color so that the layer is transparent and you can see other layers behind it. Change the 

Outline Color to something that stands out (red for example) and increase its width. 

 

Now if you display only the two layers Outlet_wtshd, and Fill_xxxx (use the checkboxes) you 

will see the topography with the outlined watershed. 

 

Determining Watershed Area 

 

To get the area of the watershed, right-click on the watershed layer (the one you converted to a 

polygon) and then select Open Attribute Table. Click on Options – Add Field (a Field is a 

column in the data table). Give the new Field a name (“Area”) and select the data type (double 

precision is a good choice for most calculations). 

 

Now right-click on your new field heading and click Calculate Geometry – select Area and the 

units you want (we often use acres or sq miles in hydrology here in the US). The value should 

appear in the area column. 

 

You can repeat these steps for the other 2 watershed areas Weston and Bachelor. Start at “Part 2” 

and make a new shapefile for your different outlet point and continue from there.  

 

I am happy to answer questions if you want to try this on your own and get stuck. My e-mail is 

liz.isenstein@gmail.com or you can stop by the graduate office ELab2 room 312.  

 

 

 

These were my results: 

 

Lake Outflow: 42.274465,-72.4704 

Watershed area is 14 square miles 

 

Weston Brook outflow: 42.26931,-72.45975 

Watershed area is about 4.9 square miles 

 

Bachelor Brook: 42.2724,-72.45894 

Watershed area is about 5.8 square miles 

 

 

 

Sources: 

 

Dr. Mi-Hyun Park, CEE 577 watershed delineation tutorial, UMASS Amherst 

 

Watershed Delineation using GIS and a DEM, CE 351, Lafayette College 

 


